Show Full FAQ List | List by Topic | Submit a Question and Answer | Visit DealMac | Alert the Admins


 




Category: iDVD

22. What do I need to be able to run iDVD2 on my Mac?

iDVD2 requires OSX, a G4 cpu, and a Pioneer superdrive on the internal IDE connector.
This works well with Macs as old as the B&W G3 when upgraded with a G4 ZIF and superdrive, and there have been reports of some success with similarly upgraded beige G3's.


Related Links:



Show Full FAQ List | List by Topic | Submit a Question and Answer | Visit DealMac | Alert the Admins